#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^http://www\.domain\.com/[^/-]+(?:-[^/-]+)+/$"
Local $sString = "http://www.domain.com/goodday/" & @CRLF & _
"http://www.domain.com/today-is-gooddady/" & @CRLF & _
"http://www.domain.com/life-is-good/enjoy-a-happy-life/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")