// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^http://www\.domain\.com/[^/-]+(?:-[^/-]+)+/$").unwrap();
let string = "http://www.domain.com/goodday/
http://www.domain.com/today-is-gooddady/
http://www.domain.com/life-is-good/enjoy-a-happy-life/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}