$re = '~^http://www\.domain\.com/[^/-]+(?:-[^/-]+)+/$~m';
$str = 'http://www.domain.com/goodday/
http://www.domain.com/today-is-gooddady/
http://www.domain.com/life-is-good/enjoy-a-happy-life/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);