import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b(?:G,C,D|A,B,C|E,C,D)|(?:[ABCDEFG](?:#|b)?)(?:\\/[ABCDEFG]b)?(?:(?:(?:maj|min|sus|add|aug|dim)(?:\\d{0,2}(?:#\\d{1,2}|sus\\d)?)?)|(?:m\\d{0,2}(?:(?:maj|add|#)\\d{0,2})?)|(?:-?\\d{0,2}(?:\\([^)]*\\)|#\\d{1,2})?))?)";
final String string = "1er couplet:\n"
+ "Gm G \n"
+ " Mon enfant, nue sur les galets\n"
+ "G D7\n"
+ " Le vent dans tes cheveux defaits\n"
+ "Dsus Cmaj\n"
+ " Comme un printemps sur mon trajet\n"
+ "C Em\n"
+ " Un diamant tombé d'un coffret";
final String subst = "[${1}]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}