const regex = /(\b(?:G,C,D|A,B,C|E,C,D)|(?:[ABCDEFG](?:#|b)?)(?:\/[ABCDEFG]b)?(?:(?:(?:maj|min|sus|add|aug|dim)(?:\d{0,2}(?:#\d{1,2}|sus\d)?)?)|(?:m\d{0,2}(?:(?:maj|add|#)\d{0,2})?)|(?:-?\d{0,2}(?:\([^)]*\)|#\d{1,2})?))?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b(?:G,C,D|A,B,C|E,C,D)|(?:[ABCDEFG](?:#|b)?)(?:\\\/[ABCDEFG]b)?(?:(?:(?:maj|min|sus|add|aug|dim)(?:\\d{0,2}(?:#\\d{1,2}|sus\\d)?)?)|(?:m\\d{0,2}(?:(?:maj|add|#)\\d{0,2})?)|(?:-?\\d{0,2}(?:\\([^)]*\\)|#\\d{1,2})?))?)', 'g')
const str = `1er couplet:
Gm G
Mon enfant, nue sur les galets
G D7
Le vent dans tes cheveux defaits
Dsus Cmaj
Comme un printemps sur mon trajet
C Em
Un diamant tombé d'un coffret`;
const subst = `[${1}]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);