// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\b(?:G,C,D|A,B,C|E,C,D)|(?:[ABCDEFG](?:#|b)?)(?:\/[ABCDEFG]b)?(?:(?:(?:maj|min|sus|add|aug|dim)(?:\d{0,2}(?:#\d{1,2}|sus\d)?)?)|(?:m\d{0,2}(?:(?:maj|add|#)\d{0,2})?)|(?:-?\d{0,2}(?:\([^)]*\)|#\d{1,2})?))?)").unwrap();
let string = "1er couplet:
Gm G
Mon enfant, nue sur les galets
G D7
Le vent dans tes cheveux defaits
Dsus Cmaj
Comme un printemps sur mon trajet
C Em
Un diamant tombé d'un coffret";
let substitution = "[${1}]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}