# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\d{3})\d/X/gm;t' <<< "19357834087
224.357.710-02"