use strict;
my $str = '19357834087
224.357.710-02';
my $regex = qr/(?<!\d{3})\d/mp;
my $subst = 'X';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";