$re = '/(?<!\d{3})\d/m';
$str = '19357834087
224.357.710-02';
$subst = "X";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;