const regex = /<b.*?\/b>\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<b.*?\\\/b>\\s*', 'g')
const str = `Your <b class =\\"b_1\\">1</b> payment due is \$4000.Your <b class =\\"b_1\\">2</b> payment due is \$3500. Your <b class =\\"b_1\\">3</b> payment due is \$5000.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}