$re = '/<b.*?\/b>\s*/';
$str = 'Your <b class =\\"b_1\\">1</b> payment due is $4000.Your <b class =\\"b_1\\">2</b> payment due is $3500. Your <b class =\\"b_1\\">3</b> payment due is $5000.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);