// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<b.*?\/b>\s*").unwrap();
let string = "Your <b class =\\\"b_1\\\">1</b> payment due is $4000.Your <b class =\\\"b_1\\\">2</b> payment due is $3500. Your <b class =\\\"b_1\\\">3</b> payment due is $5000.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}