package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<day>[\d]*)(?:-|\/)(?<month>[\d]*)(?:-|\/)(?<year>[\d]*)$`)
var str = `10-10-2013
12/09/2013`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}