re = /^(?<day>[\d]*)(?:-|\/)(?<month>[\d]*)(?:-|\/)(?<year>[\d]*)$/m
str = '10-10-2013
12/09/2013'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end