import re
regex = re.compile(r"(?<=application: label=')(.+?)(?=')")
test_str = ("package: name='com.ghisler.android.TotalCommander' versionCode='160' versionName='2.72' platformBuildVersionName='6.0-2166767'\n"
"install-location:'auto'\n"
"sdkVersion:'3'\n"
"targetSdkVersion:'23'\n"
"uses-permission: name='android.permission.WRITE_EXTERNAL_STORAGE'\n"
"uses-permission: name='android.permission.BLUETOOTH_ADMIN'\n"
"uses-permission: name='android.permission.BLUETOOTH'\n"
"uses-permission: name='android.permission.INTERNET'\n"
"uses-permission: name='android.permission.ACCESS_NETWORK_STATE'\n"
"uses-permission: name='android.permission.WAKE_LOCK'\n"
"uses-permission: name='android.permission.ACCESS_SUPERUSER'\n"
"uses-permission: name='com.android.launcher.permission.INSTALL_SHORTCUT'\n"
"uses-permission: name='com.ghisler.tcplugins.restricted'\n"
"application-label:'Total Commander'\n"
"application-icon-120:'res/drawable-ldpi-v4/icon.png'\n"
"application-icon-160:'res/drawable-v11/icon.png'\n"
"application-icon-240:'res/drawable-hdpi-v11/icon.png'\n"
"application-icon-320:'res/drawable-xhdpi-v11/icon.png'\n"
"application-icon-480:'res/drawable-xxhdpi-v11/icon.png'\n"
"application-icon-640:'res/drawable-xxhdpi-v11/icon.png'\n"
"application: label='Total Commander' icon='res/drawable-v11/icon.png'\n"
"launchable-activity: name='com.ghisler.android.TotalCommander.TotalCommander' label='Total Commander' icon=''\n"
"leanback-launchable-activity: name='com.ghisler.android.TotalCommander.TotalCommander' label='Total Commander' icon='' banner=''\n"
"uses-permission: name='android.permission.READ_EXTERNAL_STORAGE'\n"
"uses-implied-permission: name='android.permission.READ_EXTERNAL_STORAGE' reason='requested WRITE_EXTERNAL_STORAGE'\n"
"feature-group: label=''\n"
" uses-feature-not-required: name='android.hardware.bluetooth'\n"
" uses-feature-not-required: name='android.hardware.touchscreen'\n"
"main\n"
"other-activities\n"
"other-receivers\n"
"other-services\n"
"supports-screens: 'small' 'normal' 'large' 'xlarge'\n"
"supports-any-density: 'true'\n"
"locales: '--_--' 'da' 'ja' 'id' 'be' 'de' 'he' 'bg' 'vi' 'sk' 'uk' 'el' 'nl' 'pl' 'sl' 'ko' 'ro' 'fr' 'hr' 'sr' 'tr' 'cs' 'es' 'it' 'lt' 'hu' 'ru' 'sv' 'iw' 'zh-CN' 'pt-BR' 'pt-PT' 'zh-TW'\n"
"densities: '120' '160' '240' '320' '480' '640'\n"
"native-code: 'armeabi' 'mips' 'x86'\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")