import Foundation
let pattern = #"(?<=application: label=')(.+?)(?=')"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
package: name='com.ghisler.android.TotalCommander' versionCode='160' versionName='2.72' platformBuildVersionName='6.0-2166767'
install-location:'auto'
sdkVersion:'3'
targetSdkVersion:'23'
uses-permission: name='android.permission.WRITE_EXTERNAL_STORAGE'
uses-permission: name='android.permission.BLUETOOTH_ADMIN'
uses-permission: name='android.permission.BLUETOOTH'
uses-permission: name='android.permission.INTERNET'
uses-permission: name='android.permission.ACCESS_NETWORK_STATE'
uses-permission: name='android.permission.WAKE_LOCK'
uses-permission: name='android.permission.ACCESS_SUPERUSER'
uses-permission: name='com.android.launcher.permission.INSTALL_SHORTCUT'
uses-permission: name='com.ghisler.tcplugins.restricted'
application-label:'Total Commander'
application-icon-120:'res/drawable-ldpi-v4/icon.png'
application-icon-160:'res/drawable-v11/icon.png'
application-icon-240:'res/drawable-hdpi-v11/icon.png'
application-icon-320:'res/drawable-xhdpi-v11/icon.png'
application-icon-480:'res/drawable-xxhdpi-v11/icon.png'
application-icon-640:'res/drawable-xxhdpi-v11/icon.png'
application: label='Total Commander' icon='res/drawable-v11/icon.png'
launchable-activity: name='com.ghisler.android.TotalCommander.TotalCommander' label='Total Commander' icon=''
leanback-launchable-activity: name='com.ghisler.android.TotalCommander.TotalCommander' label='Total Commander' icon='' banner=''
uses-permission: name='android.permission.READ_EXTERNAL_STORAGE'
uses-implied-permission: name='android.permission.READ_EXTERNAL_STORAGE' reason='requested WRITE_EXTERNAL_STORAGE'
feature-group: label=''
uses-feature-not-required: name='android.hardware.bluetooth'
uses-feature-not-required: name='android.hardware.touchscreen'
main
other-activities
other-receivers
other-services
supports-screens: 'small' 'normal' 'large' 'xlarge'
supports-any-density: 'true'
locales: '--_--' 'da' 'ja' 'id' 'be' 'de' 'he' 'bg' 'vi' 'sk' 'uk' 'el' 'nl' 'pl' 'sl' 'ko' 'ro' 'fr' 'hr' 'sr' 'tr' 'cs' 'es' 'it' 'lt' 'hu' 'ru' 'sv' 'iw' 'zh-CN' 'pt-BR' 'pt-PT' 'zh-TW'
densities: '120' '160' '240' '320' '480' '640'
native-code: 'armeabi' 'mips' 'x86'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}