#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\w*-′]*([\[(]([\[(]?[a-zA-Zα-ωΑ-Ωµ\-′,:]+\d?[+-]?[\])]?)+[\])\d+-]{1,})[\w*-′]*)|(([A-z]+[a-z]*\d)+([A-z]+[a-z]*\d?)*)"
Local $sString = ""Fe(iii) or iron(iii) [Fe(Rtpen)X](A)n, n = 1, 2; X = Cl, Br; Rtpen = N-alkyl-N,N′,N′-tris(2-pyridylmethyl)ethane-1,2-diamine, alkyl = R = CH3CH2, CH3CH2CH2, HOCH2CH2, (CH3)2CH, C6H5, and C6H5CH2; A = ClO4, PF6."" & @CRLF & _
""iron(iii) " & @CRLF & _
"[Fe(Rtpen)(η1-OCH3)]2+ " & @CRLF & _
"[Fe(Rtpen)(η1-OOH)]2+ from iron(ii)"" & @CRLF & _
""[FeIIIOOH]2+ rather than [FeIIIOO]+ species are the p"" & @CRLF & _
"[(Rtpen)Fe(µ,η2:η2-O2)Fe(Rtpen)]4+" & @CRLF & _
"iron(iii)" & @CRLF & _
"Fe(iii)" & @CRLF & _
"[FeIIIOOH]2+" & @CRLF & _
"[Fe(Rtpen)Cl]+" & @CRLF & _
"[Fe(Rtpen)(η1-OOH)]2+" & @CRLF & _
"[Fe(Rtpen)X](A)n" & @CRLF & _
"[(Rtpen)Fe(µ,η2:η2-O2)Fe(Rtpen)]4+" & @CRLF & _
" Fe(Rtpen)(η2-OO)]+," & @CRLF & _
"N′-tris(2-pyridylmethyl)ethane-1,2-diamine" & @CRLF & _
"of [Fe(Rtpen)(η1-OOH)]2+ pro" & @CRLF & _
" (ESR, UV-vis, ESI MS) " & @CRLF & _
" [Fe(Rtpen)(η1-OOH)]2+, R = CH3CH2, CH3CH2CH2, HOCH2CH2, (CH3)2CH, C6H5, and C6H5CH2." & @CRLF & _
"f [Fe(ettpen)Cl]ClO4 instead of [Fe(bztpen)Cl]ClO4 " & @CRLF & _
"[Fe(Rtpen)Cl]A, A = ClO4, PF6, are as expected ESR silent." & @CRLF & _
"[Fe(Rtpen)Cl](PF6) and [Fe(Rtpen)Cl](PF6)2" & @CRLF & _
"e µ-oxo complex [(bztpen)ClFe(µ-O)FeCl(bztpen)](PF6)2 which could be isolated." & @CRLF & _
"H2O" & @CRLF & _
"[Fe(bztpen)Cl](ClO4)2" & @CRLF & _
" solution at 100 K, a rhombic low-spin signal (g = 2.32, 2.14, 1.93) is present in the spectra of the Fe(iii) complexes (Fig. 3a)" & @CRLF & _
")." & @CRLF & _
"" & @CRLF & _
"metpen–Fe(iii)–peroxide complexes, lead to assignment of end-on coordination for the hydroperoxide species, e.g., [Fe(Rtpen)(η1-OOH)]2+, and side-on (η2) peroxide coordination in their deprotonated derivatives, e.g., [Fe(Rtpen)(η2-OO)]+ (Scheme 1)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")