import Foundation
let pattern = #"([\w*-′]*([\[(]([\[(]?[a-zA-Zα-ωΑ-Ωµ\-′,:]+\d?[+-]?[\])]?)+[\])\d+-]{1,})[\w*-′]*)|(([A-z]+[a-z]*\d)+([A-z]+[a-z]*\d?)*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"Fe(iii) or iron(iii) [Fe(Rtpen)X](A)n, n = 1, 2; X = Cl, Br; Rtpen = N-alkyl-N,N′,N′-tris(2-pyridylmethyl)ethane-1,2-diamine, alkyl = R = CH3CH2, CH3CH2CH2, HOCH2CH2, (CH3)2CH, C6H5, and C6H5CH2; A = ClO4, PF6."
"iron(iii)
[Fe(Rtpen)(η1-OCH3)]2+
[Fe(Rtpen)(η1-OOH)]2+ from iron(ii)"
"[FeIIIOOH]2+ rather than [FeIIIOO]+ species are the p"
[(Rtpen)Fe(µ,η2:η2-O2)Fe(Rtpen)]4+
iron(iii)
Fe(iii)
[FeIIIOOH]2+
[Fe(Rtpen)Cl]+
[Fe(Rtpen)(η1-OOH)]2+
[Fe(Rtpen)X](A)n
[(Rtpen)Fe(µ,η2:η2-O2)Fe(Rtpen)]4+
Fe(Rtpen)(η2-OO)]+,
N′-tris(2-pyridylmethyl)ethane-1,2-diamine
of [Fe(Rtpen)(η1-OOH)]2+ pro
(ESR, UV-vis, ESI MS)
[Fe(Rtpen)(η1-OOH)]2+, R = CH3CH2, CH3CH2CH2, HOCH2CH2, (CH3)2CH, C6H5, and C6H5CH2.
f [Fe(ettpen)Cl]ClO4 instead of [Fe(bztpen)Cl]ClO4
[Fe(Rtpen)Cl]A, A = ClO4, PF6, are as expected ESR silent.
[Fe(Rtpen)Cl](PF6) and [Fe(Rtpen)Cl](PF6)2
e µ-oxo complex [(bztpen)ClFe(µ-O)FeCl(bztpen)](PF6)2 which could be isolated.
H2O
[Fe(bztpen)Cl](ClO4)2
solution at 100 K, a rhombic low-spin signal (g = 2.32, 2.14, 1.93) is present in the spectra of the Fe(iii) complexes (Fig. 3a)
).
metpen–Fe(iii)–peroxide complexes, lead to assignment of end-on coordination for the hydroperoxide species, e.g., [Fe(Rtpen)(η1-OOH)]2+, and side-on (η2) peroxide coordination in their deprotonated derivatives, e.g., [Fe(Rtpen)(η2-OO)]+ (Scheme 1)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)