#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(#|//)(?:.+\n)+^\1.+\n?"
Local $sString = "i want this" & @CRLF & _
"#____NOT_FOR_CUSTOMER_BEGIN________" & @CRLF & _
"not this" & @CRLF & _
"nor this" & @CRLF & _
"#________NOT_FOR_CUSTOMER_END____" & @CRLF & _
"and this" & @CRLF & _
"//____NOT_FOR_CUSTOMER_BEGIN__" & @CRLF & _
"not this again" & @CRLF & _
"nor this again" & @CRLF & _
"//__________NOT_FOR_CUSTOMER_END____" & @CRLF & _
"and this again" & @CRLF & _
"" & @CRLF & _
"//---" & @CRLF & _
"dsdsd" & @CRLF & _
"# dsds" & @CRLF & _
"" & @CRLF & _
"// dsdsd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")