re = /^(#|\/\/)(?:.+\n)+^\1.+\n?/m
str = 'i want this
#____NOT_FOR_CUSTOMER_BEGIN________
not this
nor this
#________NOT_FOR_CUSTOMER_END____
and this
//____NOT_FOR_CUSTOMER_BEGIN__
not this again
nor this again
//__________NOT_FOR_CUSTOMER_END____
and this again
//---
dsdsd
# dsds
// dsdsd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end