import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(#|//)(?:.+\\n)+^\\1.+\\n?";
final String string = "i want this\n"
+ "#____NOT_FOR_CUSTOMER_BEGIN________\n"
+ "not this\n"
+ "nor this\n"
+ "#________NOT_FOR_CUSTOMER_END____\n"
+ "and this\n"
+ "//____NOT_FOR_CUSTOMER_BEGIN__\n"
+ "not this again\n"
+ "nor this again\n"
+ "//__________NOT_FOR_CUSTOMER_END____\n"
+ "and this again\n\n"
+ "//---\n"
+ "dsdsd\n"
+ "# dsds\n\n"
+ "// dsdsd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}