use strict;
my $str = '!Screenshot 2023-01-09 at 11.30.10.png|width=476,height=137!
!Screenshot 2023-01-09 at 11.30.10.png|width=476!
!Screenshot 2023-01-09 at 11.30.10.png|height=137!
!image-2023-03-31-10-31-58-083.png!
!test_image.jpg!
!test_image.jpeg!';
my $regex = qr/!.*?.(png|jpg|jpeg|bmp)(\|(thumbnail|(width=\d+,height=\d+)|(width=\d+)|(height=\d+)))?!/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}