# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"!.*?.(png|jpg|jpeg|bmp)(\|(thumbnail|(width=\d+,height=\d+)|(width=\d+)|(height=\d+)))?!"
test_str = ("!Screenshot 2023-01-09 at 11.30.10.png|width=476,height=137!\n"
"!Screenshot 2023-01-09 at 11.30.10.png|width=476!\n"
"!Screenshot 2023-01-09 at 11.30.10.png|height=137!\n"
"!image-2023-03-31-10-31-58-083.png!\n"
"!test_image.jpg!\n"
"!test_image.jpeg!")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.