// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)!.*?.(png|jpg|jpeg|bmp)(\|(thumbnail|(width=\d+,height=\d+)|(width=\d+)|(height=\d+)))?!").unwrap();
let string = "!Screenshot 2023-01-09 at 11.30.10.png|width=476,height=137!
!Screenshot 2023-01-09 at 11.30.10.png|width=476!
!Screenshot 2023-01-09 at 11.30.10.png|height=137!
!image-2023-03-31-10-31-58-083.png!
!test_image.jpg!
!test_image.jpeg!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}