#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((^[[:alnum:]]+.*)-(\d+\.\d+\.\d+-VERS|\d+\.\d+\.\d+))"
Local $sString = "aaa1-bbb2-ccc3-dddd4-ffff5-1.0.0-VERS" & @CRLF & _
"aaa1-bbb2-ccc3-dddd4-ffff5-11.22.33-VERS" & @CRLF & _
"zzz1-bbb2-ccc3-1.0.1" & @CRLF & _
"zzz1-1.0.1-VERS" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")