import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((^[[:alnum:]]+.*)-(\\d+\\.\\d+\\.\\d+-VERS|\\d+\\.\\d+\\.\\d+))";
final String string = "aaa1-bbb2-ccc3-dddd4-ffff5-1.0.0-VERS\n"
+ "aaa1-bbb2-ccc3-dddd4-ffff5-11.22.33-VERS\n"
+ "zzz1-bbb2-ccc3-1.0.1\n"
+ "zzz1-1.0.1-VERS\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}