import re
regex = re.compile(r"((^[[:alnum:]]+.*)-(\d+\.\d+\.\d+-VERS|\d+\.\d+\.\d+))", flags=re.MULTILINE)
test_str = ("aaa1-bbb2-ccc3-dddd4-ffff5-1.0.0-VERS\n"
"aaa1-bbb2-ccc3-dddd4-ffff5-11.22.33-VERS\n"
"zzz1-bbb2-ccc3-1.0.1\n"
"zzz1-1.0.1-VERS\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")