const regex = /,\s*([\.a-zA-Z]*)>|p\.(.*),|([.a-zA-Z]*)\);/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',\\s*([\\.a-zA-Z]*)>|p\\.(.*),|([.a-zA-Z]*)\\);', 'g')
const str = `
BindableProperty.Create<Button, Xamarin.Forms.TextAlignment>(p => p.XAlign, Xamarin.Forms.TextAlignment.Center);
BindableProperty.Create<Button, Xamarin.Forms.TextAlignment>(p => p.YAlign, Xamarin.Forms.TextAlignment.Center);
BindableProperty.Create<Button, bool>(p => p.Borderless, false);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}