re = /,\s*([\.a-zA-Z]*)>|p\.(.*),|([.a-zA-Z]*)\);/
str = '
BindableProperty.Create<Button, Xamarin.Forms.TextAlignment>(p => p.XAlign, Xamarin.Forms.TextAlignment.Center);
BindableProperty.Create<Button, Xamarin.Forms.TextAlignment>(p => p.YAlign, Xamarin.Forms.TextAlignment.Center);
BindableProperty.Create<Button, bool>(p => p.Borderless, false);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end