$re = '/,\s*([\.a-zA-Z]*)>|p\.(.*),|([.a-zA-Z]*)\);/';
$str = '
BindableProperty.Create<Button, Xamarin.Forms.TextAlignment>(p => p.XAlign, Xamarin.Forms.TextAlignment.Center);
BindableProperty.Create<Button, Xamarin.Forms.TextAlignment>(p => p.YAlign, Xamarin.Forms.TextAlignment.Center);
BindableProperty.Create<Button, bool>(p => p.Borderless, false);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);