using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(loop\d|sr\d)";
string input = @"['sda', 'sdb', 'sdc', 'sr0', 'dm-0', 'dm-1', 'dm-2', 'dm-3', 'dm-4', 'loop0', 'loop1']
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}