package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(loop\d|sr\d)`)
var str = `['sda', 'sdb', 'sdc', 'sr0', 'dm-0', 'dm-1', 'dm-2', 'dm-3', 'dm-4', 'loop0', 'loop1']
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}