$re = '/(loop\d|sr\d)/';
$str = '[\'sda\', \'sdb\', \'sdc\', \'sr0\', \'dm-0\', \'dm-1\', \'dm-2\', \'dm-3\', \'dm-4\', \'loop0\', \'loop1\']
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);