package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<\/?Reference.*\/?>`)
var str = `<Reference Include="Microsoft.AspNetCore.Sockets.Common.Http, Version=1.0.0.0, Culture=neutral, PublicKeyToken=adb9793829ddae60, processorArchitecture=MSIL">
<HintPath>..\..\packages\LIB.XPTO.1.18.524.20\lib\net45\Microsoft.AspNetCore.Sockets.Common.Http.dll</HintPath>
</Reference>
<Reference Include="Microsoft.CSharp" />
<Reference Include="Microsoft.Extensions.Configuration.Abstractions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=adb9793829ddae60, processorArchitecture=MSIL">
<HintPath>..\..\packages\LIB.XPTO.1.0.1.2\lib\net45\Microsoft.Extensions.Configuration.Abstractions.dll</HintPath>
</Reference>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}