const regex = /<\/?Reference.*\/?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\\/?Reference.*\\\/?>', 'gm')
const str = `<Reference Include="Microsoft.AspNetCore.Sockets.Common.Http, Version=1.0.0.0, Culture=neutral, PublicKeyToken=adb9793829ddae60, processorArchitecture=MSIL">
<HintPath>..\\..\\packages\\LIB.XPTO.1.18.524.20\\lib\\net45\\Microsoft.AspNetCore.Sockets.Common.Http.dll</HintPath>
</Reference>
<Reference Include="Microsoft.CSharp" />
<Reference Include="Microsoft.Extensions.Configuration.Abstractions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=adb9793829ddae60, processorArchitecture=MSIL">
<HintPath>..\\..\\packages\\LIB.XPTO.1.0.1.2\\lib\\net45\\Microsoft.Extensions.Configuration.Abstractions.dll</HintPath>
</Reference>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}