package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<name>.*?)(?: \((?P<year>\d*)\))?$`)
var str = `abc (2022)
def
longer name (222)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}