re = /^(?P<name>.*?)(?: \((?P<year>\d*)\))?$/m
str = 'abc (2022)
def
longer name (222)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end