$re = '/^(?P<name>.*?)(?: \((?P<year>\d*)\))?$/m';
$str = 'abc (2022)
def
longer name (222)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);