#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sxmu)[*\s]* # multiple space or asterisk characters" & @CRLF & _
"@ # followed by the @ sign which" & @CRLF & _
"(?P<name>[\w\\]+) # has a string of \w or \ characters following it" & @CRLF & _
"\s*\(? # separated by spaces and maybe opening parenthesis" & @CRLF & _
" (?P<value> # store the value attached to the named annotation" & @CRLF & _
" (?:" & @CRLF & _
" [^@]* # value is made of enlisted characters" & @CRLF & _
" [^*\s)] # but does not end with" & @CRLF & _
" )" & @CRLF & _
" )? # the value is optional parameter" & @CRLF & _
"(?:\s|\n|\))"
Local $sString = "/**" & @CRLF & _
" * @Name Test" & @CRLF & _
" * @Response /test" & @CRLF & _
" * @Right ROLE_ADMIN" & @CRLF & _
" * @param Test" & @CRLF & _
" */"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")