$re = '/[*\s]* # multiple space or asterisk characters
@ # followed by the @ sign which
(?P<name>[\w\\\\]+) # has a string of \w or \ characters following it
\s*\(? # separated by spaces and maybe opening parenthesis
(?P<value> # store the value attached to the named annotation
(?:
[^@]* # value is made of enlisted characters
[^*\s)] # but does not end with
)
)? # the value is optional parameter
(?:\s|\n|\))/sxmu';
$str = '/**
* @Name Test
* @Response /test
* @Right ROLE_ADMIN
* @param Test
*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);