// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sxmu)[*\s]* # multiple space or asterisk characters
@ # followed by the @ sign which
(?P<name>[\w\\]+) # has a string of \w or \ characters following it
\s*\(? # separated by spaces and maybe opening parenthesis
(?P<value> # store the value attached to the named annotation
(?:
[^@]* # value is made of enlisted characters
[^*\s)] # but does not end with
)
)? # the value is optional parameter
(?:\s|\n|\))").unwrap();
let string = "/**
* @Name Test
* @Response /test
* @Right ROLE_ADMIN
* @param Test
*/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}