# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{{(?>[^}{]*(?R)?)*}} ?//g;t' <<< "Hello {{world of the {{ crazy}} {{need {{ be}}}} sea }} there.
Hello {{world of the {{ crazy}} {{need {{ be}}}} sea }} there {{my }} friend.
"