use strict;
my $str = 'Hello {{world of the {{ crazy}} {{need {{ be}}}} sea }} there.
Hello {{world of the {{ crazy}} {{need {{ be}}}} sea }} there {{my }} friend.
';
my $regex = qr/{{(?>[^}{]*(?R)?)*}} ?/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";