#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "{{(?>[^}{]*(?R)?)*}} ?"
Local $sString = "Hello {{world of the {{ crazy}} {{need {{ be}}}} sea }} there." & @CRLF & _
"" & @CRLF & _
"Hello {{world of the {{ crazy}} {{need {{ be}}}} sea }} there {{my }} friend." & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)