using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(4\d\d|5([0-4]\d|50))";
string input = @"400
401
390
501
550
549
551";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}