package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(4\d\d|5([0-4]\d|50))`)
var str = `400
401
390
501
550
549
551`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}