$re = '/(4\d\d|5([0-4]\d|50))/';
$str = '400
401
390
501
550
549
551';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);