#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]|[12][0-9]|3[01])$"
Local $sString = "1" & @CRLF & _
"13" & @CRLF & _
"44" & @CRLF & _
"22" & @CRLF & _
"53" & @CRLF & _
"30" & @CRLF & _
"31" & @CRLF & _
"32"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")