package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9]|[12][0-9]|3[01])$`)
var str = `1
13
44
22
53
30
31
32`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}