$re = '/^([1-9]|[12][0-9]|3[01])$/m';
$str = '1
13
44
22
53
30
31
32';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);